icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.dainali.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

7089彩票 www.942088.com-凤彩下载-| www.bx25.com-全国快三开奖结果| www.15802.com-下载体彩软件| www.123323.com-快三赢钱-| 好彩www.60123s.com| www.222235.com-彩票网注册送28| www.108119.com-梦到彩票号码很准| www.383643.com-实时彩代理平台出租| www.yc92.com-福彩3d图谜总汇总| www.jo93.com-福州快三查询| www.870176.com-福彩30万是真是假| www.170508.com-易彩-彩民福地登录| www.ur12.com-淘彩吧论坛首页| www.cp8114.com-彩票王牌app| www.54bv.com-凯里福利彩票| www.954926.com-黑彩余额修改器下载| www.278646.com-一分快三怎样抓豹子| www.444279.com-中彩网正版下载安装| www.578334.com-腾讯五分彩规则| www.699913.com-中国福彩开奖号| www.846182.com-七乐乐彩开讲结果| www.5gw.com-福甘肃快三彩开奖| www.su39.com-体彩七星彩怎么中奖| www.55px.com-足彩5800万-| www.5305.pw-17081期七星彩| www.8425.cm-快三咋样才能中奖| www.769071.com-3d选号彩报18年| www.cy82.com-人人彩票网官网首页| www.898077.com-网络彩票害人| www.994959.com-好彩堂好彩堂论坛| www.sa49.com-快三2豹的规律| www.571253.com-石敢当好彩妹原型| www.590565.com-七星彩宣传图片| www.692279.com-彩票开奖直播大乐透| www.371517.com-577彩票可靠吗| www.127503.com-最新彩虹世界安卓| www.235589.com-山东省彩票沙龙| www.345173.com-棋牌彩票代理有罪吗| www.480742.com-百度双彩论坛| www.577863.com-重庆分分彩官网网址| www.671414.com-福彩三地彩乐园| www.760601.com-江苏体彩七数| www.856700.com-海南彩票规律| www.969464.com-宝马彩票计划网址| www.cp1777.com-幸运快三在线计划| www.sr05.com-彩票开奖是直播吗| 人人彩票www.rrle7.com| www.yb10.cc-足彩app叫停| www.867308.com-v8时时彩-| www.968972.com-最近彩票诈骗案例| www.tk8.com-爱彩乐计划-| www.800827.com-福彩3d天天开奖| www.698484.com-天津时时彩开奖漏洞| www.841108.com-福利彩票的属性| www.926530.com-购彩lll邀请码| www.cp2017.cc-中国快三网-| www.203590.com-内苎快三预测| www.133460.com-梧桐彩票网站| www.333536.com-数学家研究彩票投注| www.585195.com-懂彩宝双色球| www.867843.com-澳门彩票网站| www.gn45.com-进口彩妆加盟店| www.788956.com-竞彩的专家的重要性| www.936687.com-七乐彩复式中奖结果| www.sy62.com-手机彩票平台哪个好| www.2078.cc-沈阳二手旋风彩虹机| www.480228.com-彩宝贝杀红-| www.586283.com-彩票研究都是白费| www.704789.com-彩068彩票-| www.872336.com-贵州省体彩中心电话| www.pw50.com-三分时时彩是哪里的| www.81sw.com-综艺福彩是真的吗| www.185667.com-福彩的宗旨-| www.88564.com-彩票站出票错了| www.151005.com-彩漂液能去衣服串色| www.106695.com-七星彩今天-| www.671521.com-3d彩宝网走势| 博友彩www.359932.com| www.076999.com-国外彩票名称| www.015702.com-够力七星彩规律图| www.96jb.com-高频彩吧登陆| www.0180.net-谁知道赢彩网| www.920282.com-彩票计划86在线网| 500彩票www.330872.com| www.189855.com-湖北快三怎么玩| www.741126.com-澳门赛马彩票| www.523199.com-重庆桥下彩票研究| www.707596.com-彩票3d组六走势| www.830129.com-盈彩娱乐官方| 全民彩票www.qm71.com| www.28626.com-台湾福星彩玄机料| www.37269.cc-一分快三开挂器| www.395663.com-奇门测彩3d实例| www.618034.com-必中彩票网提现| www.700025.cc-竞彩足球跟单靠谱吗| www.792068.com-福彩怎么兑奖| www.175971.com-大发快三大小技巧| www.355429.com-彩友网949cc| www.634376.com-福彩双色球专家对比| www.793710.com-彩票网站赌博| www.0130.loan-彩色算颜色的词语吗| www.535761.com-彩票计算器助手| www.630375.com-体彩飞鱼口诀汉字四| www.771478.com-快三组三的技巧| www.870719.com-卓易彩票苹果app| PK彩票www.8499o.com| 彩客吧www.88ckb.com| www.ao80.com-贵州中彩票-| www.ny90.com-广东福彩快乐| www.451002.com-打黑彩票欠钱用给吗| www.63319.cc-杨震谈足彩-| www.505010.com-竞彩混合过关中奖| www.181221.com-快三中奖金额是多少| www.868875.com-七星彩海南奖头尾| www.026105.com-007彩票网-| www.122822.cc-8k彩票破解方法| www.514127.com-美国强力球彩票代购| www.zc12.cc-买快三彩票是赌博吗| www.uu87.com-广西体彩中奖彩票| www.40uc.com-唯彩会官网首页| www.127929.com-与彩虹有关的歌词| www.047.org-彩票收藏文化| www.6101.vip-骨瓷釉上彩有毒吗| www.47hd.com-亿彩网下载-| www.54ye.com-彩票兑换中心商品| www.962283.com-山东体彩中心地址| www.20jy.com-19004期足彩| www.561573.com-彩工网推荐快三| www.600659.com-彩票从哪里买| www.65ag.com-微信彩票下载安装| www.304876.com-易彩网彩票下载| www.cai0234.com彩票快三是什么意思| www.918853.com-香港巨额彩票要交税| www.76pr.com-买动物的彩票| www.3625.cn-万彩app可靠吗| www.77422.com-统计学与彩票| www.959137.com-旺彩彩票能网络购彩| www.99832.cc-彩票中奖搞笑图片| www.627373.com-中彩中福快三| www.779425.com-中彩易是真的吗| www.906391.com-送彩金平台-| 68彩票www.68682a.com| www.91487.com-绿好彩是爆珠烟吗| www.055685.com-彩种最全的彩票| www.698368.com-彩虹颜色的顺序图片| www.826133.com-2元彩票图表| www.538678.com-赢彩门户网站| www.163064.com-福彩排列三走势结果| www.de17.com-cp彩票靠谱吗| www.8lh.com-黄金定律彩票应用| www.76hm.com-马耳他彩票开奖| www.9985.top-彩色压印混凝土广场| www.763467.com-买足球竞彩绝招| www.006409.com-泰国好彩薄荷双爆珠| www.501554.com-新彩吧3地字谜| www.556366.cc-彩票中奖兑奖地点| www.635616.com-七彩阳光视-| www.697398.com-玩时时彩的软件| www.095201.com-快三买大小技巧| www.630451.com-九w彩票-| www.136086.com-足彩缩水软件手机版| www.258759.com-竞彩蓝球专家推荐| www.322711.com-网易买彩票-| www.150760.com-国民彩票中文字幕|